Get Your Website’s Google Map Plugin Working Again

With WordPress upgrading to version 3.6 this week, JQuery failed to update which meant that the popular Comprehensive Google Map Plugin stopped showing where in the world you are and displayed the error:

Comprehensive Google Map Plugin JQuery error“ATTENTION! (by Comprehensive Google Map Plugin).

Your blog/site theme or one of your plugins uses jQuery javascript library which is older than the version 1.3.0. The Comprehensive Google Map plugin will not work with such outdated jQuery version.

The minimum jQuery requirement for Comprehensive Google Map plugin is version 1.3.0. Apologies for the inconvenience.”

‘Inconvenient’ was an understatement. Basically, 3.6 installed the old version of JQuery. jQuery, according to Wikipedia, “is a multi-browser (cf. cross-browser) JavaScript library designed to simplify the client-side scripting of HTML.” Yep, means nothing to a pleb like me.

And being a pleb, i i was dismayed to read the many, complicated coding suggestions people were giving to fix this problem. And that nightmare was multiplied by 6 client sites that i needed to fix (thankfully, only one had noticed the problem so far).

Then i hit upon the simplest solution in the world which made me want to kiss a 24-yeal old Dutch dude called Ramoonus – i kid you not. He made a plugin (programme) that once installed makes updating JQuery super easy.

  1. Deactivate Comprehensive Google Map Plugin.
  2. Go to http://wordpress.org/plugins/jquery-updater and install it.
  3. Activate JQuery Updater.
  4. Reactivate Comprehensive Google Map Plugin.

Ramoonus also makes dance music which under normal circumstances i would kill with some Mastodon or chill-to-forget with Matt Corby. But, today, as a thank you for his brain at work, i give you:

 

Leave a Reply

  1. Wow !! Its just awesome it worked very pretty 🙂 Thank you so much for wonderful tip Ramoonus…… And your song is just mind blowing enjoyed it.

  2. SWEET!!!

    Thanks for that. Such a simple and fast fix as well.

    I had fixed this issue by hacking the plugin’s core files on another site.

    May I link this article on my site?

    Felixius

  3. Thanks for this! Such a simple solution..for me…not so simple for the dude who made the plugin. BIG thanks to Rammonus!

  4. HI,

    thanks for your articel. I just wanted to make two remarks:
    It’s not true that WP3.6 installs an old version of jQuery, it installs a version 1.10. Herein lies the problem. 1.10 means it is major version 1 and sub version 10, which is newer then (let’s say) 1.9. What the plugin does is comparing numbers ans the number 1.3 is mathematically greater then 1.10.

    The jquery-updater installs (at time of posting) a 2.x version which is mathematically greater than 1.3 (which is the minimum version required by the maps-plugin).

    So that is just fine.

    There is only one consideration: jQuery 2.x dropped support for (very) old Browsers (i.e. IE6). While 1.9, 1.10 and so on… still support those.

    By taking your approach you will most likely run into some trouble withe those older browsers. (Fine with me, I’d like to forget about them as soon as possible) but I just thought I’d mention it, as your site is one of the tophits when goggling for the problem.

  5. Joining the chorus of thank you’s! This was the maps plugin I wanted to use, but was starting to look elsewhere when I found your post. Thanks for making it easily possible!